2021/04/23 WhatYaの障害を解消いたしました。
発生内容:接続エラー
STATUS:対応完了
TYPE:インシデント
開始時間: 2021年4月23日 12:00
更新時間: 2021年4月23日 12:21
影響を受けるコンポーネント:
WhatYa V2
影響:
本日 2021/04/20 12:00頃より発生しておりました、WhatYa V2をご利用のお客様へ、繋がりにくい状況が発生しておりましたが、同日 12:22頃問題が解消していることを確認いたしました。
本件の影響範囲・発生期間・原因・対策につきましては、以下のとおりとなります。
影響範囲:
全クライアント(一部のユーザーとタイミングにて発生)
※ロードバランサーで障害のあるサーバーへ割り振られた場合、
3時間後にはスティッキーセッションの初期化が行われています。
障害発生時期:
2021-04-20 19:23:55.833 ~ 2021/04/23 11:57:29
原因:
①双方向通信用のサーバーの破損による再起動を実施した際、クライアントコンフィグ情報をNullで取得し、再起動を行ったサーバーが発生。
結果、個別のクライアントからのレスポンスを受け取ることが出来ないサーバーが存在することになってしまった。
②クライアントコンフィグ情報の取得において、ソースコード上の問題があり、改修を実施。この改修の適用が、障害発生時期の後であったために、①のサーバーへは改修パッチ後の処理が適用されず、レスポンスを受けられないサーバーが存在し続けることになり、経過してしまった。
③該当の双方向通信サーバーからのシステムエラーがなかった(コンフィグがNullでも正常起動してしまった)為、発生した事象に気づくことが出来なかった。
対策:
①再デプロイ(新規)したことにより、問題解消
②上記、デプロイにより問題解消
③起動時のコンフィグ取得に関するバリデーション追加の改修を行う(現在、改修中)
以上となります。
ご不便をおかけし大変申し訳ございませんでした。