【OKSKY】同じ来訪者なのにルームが別になってしまいます。
OK SKY
質問1
同じ来訪者なのにルームが別になってしまいます。同じルームで会話を続けるためにはどうしたらいいですか?
通常、来訪者のチャットが2度目であっても、来訪者を特定して前回と同じルームから会話を再開します。そして来訪者側のチャットにも過去のメッセージを表示させます。
こちらはCookieを利用して来訪者を特定する事で実現しています。その為、Cookieから前回の情報が取得できない場合はルームが新しくなります。
また、計測するためのログもCookieが書き変わるとidが新しくなるので、チャットを利用したユーザーがサンクスページに到達する前に新しいidになり、計測されない場合があります。
解決策
Cookieは以下利用環境の条件により、新しく作成される為、Cookieの更新が発生すると、過去の会話は継続されず、ルームが新規になります。
・ブラウザの仕様や設定によりCookieの有効期限が切れた
・ページ遷移をするとサブドメインごと変わる(ドメインが変わる)
・Cookieを手動で削除した
・デバイスやブラウザが変わったとき
Cookieは来訪者側のデバイス(スマホ・PC)やブラウザに依存するので、こちらから制御できません。
従って解決策としては、Cookieに関係なく、継続的に会話を継続したい場合はID連携のご利用をご検討下さい。
質問2
同じ来訪者のルームが頻繁に新しくなってしまいます。どうしてでしょうか?
また、以下の様にお客様サイトに異なるドメインのOK SKYが導入されていると、頻繁にルームが更新される事象が発生します。
お客様ECサイト
└商品A aaa.oksky.com
└商品B bbb.oksky.com
原因
例えば来訪者が「aaa.oksky.com」でチャットを使います。この来訪者がこの後「bbb.oksky.com」
のチャットをそのまま利用すると、最初にアクセスした「aaa.oksky.com」のCookieが「bbb.oksky.com」のCookieに上書きされてしまう為、頻繁にルームが更新されてしまうような事象が起きます。
計測するためのログもCookieを利用している為、Cookieの情報が変わると、aaa.oksky.com のid情報が保持されずbbb.oksky.comのidに変わってしまう為、aaa.oksky.comが追えなくなり、不自然な計測値になる場合があります。
解決策
この事象の解決策は以下となります
・異なるOK SKYではなく同一のOK SKYで管理を行う
・会員情報連携を行う
Cookieの問題を考慮すると、1つのお客様環境に、異なる環境のOK SKYを導入しない事を推奨します。
Related articles
ラベルで絞り込み
現在、選択したラベルのアイテムはありません。